CVE-2020-11022 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars.npm:jquery. 8 public exploit references exist, so weaponization risk is real. A fix is available for org.webjars.npm:jquery — see the affected versions and patch details below.
Potential XSS vulnerability in jQuery
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2020-11022 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 397,508 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
jquerynpmDescription
Impact
Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code.
Patches
This problem is patched in jQuery 3.5.0.
Workarounds
To workaround the issue without upgrading, adding the following to your code:
jQuery.htmlPrefilter = function( html ) {
return html;
};
You need to use at least jQuery 1.12/2.2 or newer to be able to apply this workaround.
References
https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ https://jquery.com/upgrade-guide/3.5/
For more information
If you have any questions or comments about this advisory, search for a relevant issue in the jQuery repo. If you don't find an answer, open a new issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.webjars.npm:jquery | ≥ 1.12.0&&< 3.5.0 | 3.5.0org.webjars.npm:jquery:3.5.0 |
| 📦npm | jquery | ≥ 1.12.0&&< 3.5.0 | 3.5.0npm install jquery@3.5.0 |
| .NETNuGet | jquery | ≥ 1.12.0&&< 3.5.0 | 3.5.0dotnet add package jquery --version 3.5.0 |
| 🐘Packagist | maximebf/debugbar | all versions | 1.19.0composer require maximebf/debugbar:^1.19.0 |
| 🐘Packagist | athlon1600/youtube-downloader | all versions | 4.0.1composer require athlon1600/youtube-downloader:^4.0.1 |
| 🐘Packagist | components/jquery | ≥ 1.12.0&&< 3.5.0 | 3.5.0composer require components/jquery:^3.5.0 |
Affected Products
debian linuxdebiandrupaldrupalfedorafedoraprojectjqueryjqueryh300e firmwarenetapph300s firmwarenetappResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
jQuery 1.2 - Cross-Site Scripting (XSS)
by Central InfoSec · Apr 14, 2021
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:jquery, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.webjars.npm:jquery to 3.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-11022 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
No supported release of Red Hat OpenStack Platform is affected by this vulnerability as no shipped packages contain the vulnerable code.
| Product | Fixed in | Advisory |
|---|---|---|
| A-MQ Interconnect 1.y for RHEL 6 | qpid-dispatch-0:1.13.0-3.el6_10 | RHSA-2020:4211 |
| Openshift Service Mesh 1.0 | jaeger-0:v1.13.1.redhat7-1.el7 | RHSA-2020:2362 |
| Red Hat Ansible Tower 3.6 for RHEL 7 | ansible-tower-36/ansible-tower:3.6.7-1 | RHSA-2021:0778 |
| Red Hat Ansible Tower 3.7 for RHEL 7 | ansible-tower-37/ansible-tower-rhel7:3.7.4-1 | RHSA-2020:5249 |
| Red Hat Enterprise Linux 7 | ipa-0:4.6.8-5.el7 | RHSA-2020:3936 |
| Red Hat Enterprise Linux 8 | idm:client-8030020200923172426.05ac3f11 | RHSA-2020:4670 |
| Red Hat Enterprise Linux 8 | pki-core:10.6-8030020200911215836.5ff1562f | RHSA-2020:4847 |
| Red Hat JBoss Enterprise Application Platform 7.4.9 | org.jboss.hal/hal-console:3.3.16.Final-redhat-00001 | RHSA-2023:0556 |
Frequently Asked Questions
Is CVE-2020-11022 in your dependencies?
Find it across Maven, npm, NuGet, including transitive dependencies.