NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-8008 — storm-core

MEDIUMFix: apache/storm@0fc6b52

CVE-2018-8008 is a medium-severity (CVSS 5.5) Path Traversal vulnerability in org.apache.storm:storm-core. A fix is available for org.apache.storm:storm-core — see the affected versions and patch details below.

ZipSlip in org.apache.storm:storm-core

Also known asGHSA-898j-5cc8-cmf5
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk-0.08%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%6.43%12.9%19.3%15.3%2.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.storm:storm-core☕org.apache.storm:storm-core☕org.apache.storm:storm-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose an arbitrary file write vulnerability, that can be achieved using a specially crafted zip archive (affects other archives as well, bzip2, tar, xz, war, cpio, 7z), that holds path traversal filenames. So when the filename gets concatenated to the target extraction directory, the final path ends up outside of the target folder.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.storm:storm-core≥ 1.1.0&&< 1.1.31.1.3org.apache.storm:storm-core:1.1.3
☕Mavenorg.apache.storm:storm-core≥ 1.2.0&&< 1.2.21.2.2org.apache.storm:storm-core:1.2.2
☕Mavenorg.apache.storm:storm-coreall versions1.0.7org.apache.storm:storm-core:1.0.7

Affected Products

1 product · 3 configurations
Application
stormapache
≤ 1.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.storm:storm-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.storm:storm-core to 1.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-8008 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose an arbitrary file write vulnerability, that can be achieved using a specially crafted zip archive (affects other archives as well, bzip2, tar, xz, war, cpio, 7z), that holds path traversal filenames. So when the filename gets concatenated to the target extraction directory, the final path ends up outside of the target folder.
O3 Security · Impact-Aware SCA

Is CVE-2018-8008 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-8008: storm-core Path Traversal — Fixed in 1.1.3