NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2018-1331 — storm-core

HIGH

CVE-2018-1331 is a high-severity (CVSS 8.8) remote code execution vulnerability in org.apache.storm:storm-core. A fix is available for org.apache.storm:storm-core — see the affected versions and patch details below.

Code execution in org.apache.storm:storm-core

Also known asGHSA-p8jx-x2vw-wm33
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
3.92%4.49%5.05%5.61%5.1%4.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.storm:storm-core☕org.apache.storm:storm-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Storm 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, and 1.2.0 through 1.2.1, an attacker with access to a secure storm cluster in some cases could execute arbitrary code as a different user.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.storm:storm-core≥ 1.2.0&&< 1.2.21.2.2org.apache.storm:storm-core:1.2.2
☕Mavenorg.apache.storm:storm-coreall versions1.1.3org.apache.storm:storm-core:1.1.3

Affected Products

1 product · 4 configurations
Application
stormapache
≥ 1.2.0 && ≤ 1.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.storm:storm-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.storm:storm-core to 1.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1331 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In Apache Storm 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, and 1.2.0 through 1.2.1, an attacker with access to a secure storm cluster in some cases could execute arbitrary code as a different user.
O3 Security · Impact-Aware SCA

Is CVE-2018-1331 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1331: storm-core RCE — Fixed in 1.2.2