NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1332 — storm-core

MEDIUM

CVE-2018-1332 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in org.apache.storm:storm-core. A fix is available for org.apache.storm:storm-core — see the affected versions and patch details below.

Moderate severity vulnerability that affects org.apache.storm:storm-core

Also known asGHSA-q35p-chc6-7x57
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk-0.05%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.66%1.32%1.98%0.4%1.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.storm:storm-core☕org.apache.storm:storm-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.storm:storm-coreall versions1.1.3org.apache.storm:storm-core:1.1.3
☕Mavenorg.apache.storm:storm-core≥ 1.2.0&&< 1.2.21.2.2org.apache.storm:storm-core:1.2.2

Affected Products

1 product · 3 configurations
Application
stormapache
≤ 1.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.storm:storm-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.storm:storm-core to 1.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1332 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.
O3 Security · Impact-Aware SCA

Is CVE-2018-1332 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1332: storm-core — Fixed in 1.1.3