NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2017-9799 — storm-core

HIGH

CVE-2017-9799 is a high-severity (CVSS 8.8) vulnerability in org.apache.storm:storm-core. A fix is available for org.apache.storm:storm-core — see the affected versions and patch details below.

Apache Storm it is possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user

Also known asGHSA-x825-rjww-2245
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%2.02%4.04%6.07%0.9%4.9%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.storm:storm-core☕org.apache.storm:storm-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

It was found that under some situations and configurations of Apache Storm 1.x before 1.0.4 and 1.1.x before 1.1.1, it is theoretically possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user. In the worst case this could lead to secure credentials of the other user being compromised.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.storm:storm-core≥ 1.1.0&&< 1.1.11.1.1org.apache.storm:storm-core:1.1.1
☕Mavenorg.apache.storm:storm-core≥ 1.0.0&&< 1.0.41.0.4org.apache.storm:storm-core:1.0.4

Affected Products

1 product · 5 configurations
Application
stormapache
5 versions
1.01.0.11.0.21.0.31.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.storm:storm-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.storm:storm-core to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-9799 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

It was found that under some situations and configurations of Apache Storm 1.x before 1.0.4 and 1.1.x before 1.1.1, it is theoretically possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user. In the worst case this could lead to secure credentials of the other user being compromised.
O3 Security · Impact-Aware SCA

Is CVE-2017-9799 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-9799: storm-core — Fixed in 1.1.1