CVE-2018-0504 — core
MEDIUMCVE-2018-0504 is a medium-severity (CVSS 6.5) CWE-532 vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.
Mediawiki information disclosure vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mediawiki/core🐘mediawiki/core🐘mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains an information disclosure flaw in the Special:Redirect/logid
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | ≥ 1.27.0&&< 1.27.5 | 1.27.5composer require mediawiki/core:^1.27.5 |
| 🐘Packagist | mediawiki/core | ≥ 1.29.0&&< 1.29.3 | 1.29.3composer require mediawiki/core:^1.29.3 |
| 🐘Packagist | mediawiki/core | ≥ 1.30.0&&< 1.30.1 | 1.30.1composer require mediawiki/core:^1.30.1 |
| 🐘Packagist | mediawiki/core | ≥ 1.31.0&&< 1.31.1 | 1.31.1composer require mediawiki/core:^1.31.1 |
Affected Products
debian linuxdebianmediawikimediawikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.27.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-0504 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | mediawiki-0:1.27.7-1.el7 | RHSA-2019:3238 |
| Red Hat OpenShift Container Platform 3.9 | mediawiki123-0:1.23.17-1.el7 | RHSA-2019:3813 |
Frequently Asked Questions
Is CVE-2018-0504 in your dependencies?
Find it across Packagist, including transitive dependencies.