NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2017-5635 — nifi

HIGH

CVE-2017-5635 is a high-severity (CVSS 7.5) Improper Authentication vulnerability in org.apache.nifi:nifi. A fix is available for org.apache.nifi:nifi — see the affected versions and patch details below.

Improper Authentication In Apache NiFi

Also known asGHSA-jgj9-6v78-6g8m
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.00%1.38%2.76%4.14%0.5%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.nifi:nifi☕org.apache.nifi:nifi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, if an anonymous user request is replicated to another node, the originating node identity is used rather than the "anonymous" user.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.nifi:nifiall versions0.7.2org.apache.nifi:nifi:0.7.2
☕Mavenorg.apache.nifi:nifi≥ 1.0.0&&< 1.1.21.1.2org.apache.nifi:nifi:1.1.2

Affected Products

1 product · 4 configurations
Application
nifiapache
4 versions
0.7.00.7.11.1.01.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.nifi:nifi to 0.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5635 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, if an anonymous user request is replicated to another node, the originating node identity is used rather than the "anonymous" user.
O3 Security · Impact-Aware SCA

Is CVE-2017-5635 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-5635: nifi — Fixed in 0.7.2