NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-33140 — nifi-registry-core

HIGH

CVE-2022-33140 is a high-severity (CVSS 8.8) OS Command Injection vulnerability in org.apache.nifi.registry:nifi-registry-core. A fix is available for org.apache.nifi.registry:nifi-registry-core — see the affected versions and patch details below.

Code injection in Apache NiFi and NiFi Registry

Also known asBIT-nifi-2022-33140GHSA-77hf-23pq-2g7c
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
3.15%3.56%3.97%4.38%3.9%3.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.nifi.registry:nifi-registry-core☕org.apache.nifi:nifi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The optional ShellUserGroupProvider in Apache NiFi 1.10.0 to 1.16.2 and Apache NiFi Registry 0.6.0 to 1.16.2 does not neutralize arguments for group resolution commands, allowing injection of operating system commands on Linux and macOS platforms. The ShellUserGroupProvider is not included in the default configuration. Command injection requires ShellUserGroupProvider to be one of the enabled User Group Providers in the Authorizers configuration. Command injection also requires an authenticated user with elevated privileges. Apache NiFi requires an authenticated user with authorization to modify access policies in order to execute the command. Apache NiFi Registry requires an authenticated user with authorization to read user groups in order to execute the command. The resolution removes command formatting based on user-provided arguments.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.nifi.registry:nifi-registry-core≥ 0.6.0&&< 1.16.31.16.3org.apache.nifi.registry:nifi-registry-core:1.16.3
☕Mavenorg.apache.nifi:nifi≥ 1.10.0&&< 1.16.31.16.3org.apache.nifi:nifi:1.16.3

Affected Products

2 products · 2 configurations
Application
nifiapache
≥ 1.10.0 && ≤ 1.16.2
range
Application
nifi registryapache
≥ 0.6.0 && ≤ 1.16.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi.registry:nifi-registry-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.nifi.registry:nifi-registry-core to 1.16.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-33140 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The optional ShellUserGroupProvider in Apache NiFi 1.10.0 to 1.16.2 and Apache NiFi Registry 0.6.0 to 1.16.2 does not neutralize arguments for group resolution commands, allowing injection of operating system commands on Linux and macOS platforms. The ShellUserGroupProvider is not included in the default configuration. Command injection requires ShellUserGroupProvider to be one of the enabled User Group Providers in the Authorizers configuration. Command injection also requires an authenticated user with elevated privileges. Apache NiFi requires an authenticated user with authorization to modi
O3 Security · Impact-Aware SCA

Is CVE-2022-33140 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-33140: nifi-registry — Fixed in 1.16.3