CVE-2017-7665 — nifi
MEDIUMCVE-2017-7665 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.nifi:nifi. A fix is available for org.apache.nifi:nifi — see the affected versions and patch details below.
Cross-site Scripting in Apache NiFi
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.nifi:nifi☕org.apache.nifi:nifiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.nifi:nifi | all versions | 0.7.4org.apache.nifi:nifi:0.7.4 |
| ☕Maven | org.apache.nifi:nifi | ≥ 1.0.0&&< 1.3.0 | 1.3.0org.apache.nifi:nifi:1.3.0 |
Affected Products
nifiapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.nifi:nifi to 0.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7665 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-7665 in your dependencies?
Find it across Maven, including transitive dependencies.