CVE-2017-7667 — nifi
HIGHCVE-2017-7667 is a high-severity (CVSS 7.5) CWE-346 vulnerability in org.apache.nifi:nifi. A fix is available for org.apache.nifi:nifi — see the affected versions and patch details below.
Origin Validation Error in Apache NiFi
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.nifi:nifi☕org.apache.nifi:nifiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache NiFi before 0.7.4 and 1.x before 1.3.0 need to establish the response header telling browsers to only allow framing with the same origin.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.nifi:nifi | all versions | 0.7.4org.apache.nifi:nifi:0.7.4 |
| ☕Maven | org.apache.nifi:nifi | ≥ 1.0.0&&< 1.3.0 | 1.3.0org.apache.nifi:nifi:1.3.0 |
Affected Products
nifiapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.nifi:nifi to 0.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7667 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-7667 in your dependencies?
Find it across Maven, including transitive dependencies.