NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-8748 — nifi

MEDIUM

CVE-2016-8748 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.apache.nifi:nifi. A fix is available for org.apache.nifi:nifi — see the affected versions and patch details below.

Cross-site Scripting in Apache NiFi

Also known asGHSA-g2fm-x3cp-mqw9
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%0.83%1.66%2.49%0.4%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.nifi:nifi☕org.apache.nifi:nifi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.nifi:nifiall versions1.0.1org.apache.nifi:nifi:1.0.1
☕Mavenorg.apache.nifi:nifi≥ 1.1.0&&< 1.1.11.1.1org.apache.nifi:nifi:1.1.1

Affected Products

1 product · 2 configurations
Application
nifiapache
≤ 1.0.0
1 version
1.1.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.nifi:nifi to 1.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-8748 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.
O3 Security · Impact-Aware SCA

Is CVE-2016-8748 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-8748: nifi XSS — Fixed in 1.0.1