CVE-2017-10689 is a medium-severity (CVSS 5.5) Improper Privilege Management vulnerability in puppet. A fix is available for puppet — see the affected versions and patch details below.
Tarball permission preservation in puppet
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
puppet💎puppetReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
When installing a module using the system tar, the PMT will filter filesystem permissions to a sane value. This may just be based on the user's umask.
When using minitar, files are unpacked with whatever permissions are in the tarball. This is potentially unsafe, as tarballs can be easily created with weird permissions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | puppet | all versions | 4.10.10bundle update puppet --conservative |
| 💎RubyGems | puppet | ≥ 5.0.0&&< 5.3.4 | 5.3.4bundle update puppet --conservative |
Affected Products
ubuntu linuxcanonicalpuppetpuppetpuppet enterprisepuppetsatelliteredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for puppet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update puppet to 4.10.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-10689 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Product Security has rated this issue as having security impact of Low. This issue affects the versions of puppet as shipped with: * Red Hat Satellite 6. A future update may address this issue. * Red Hat OpenStack Platform versions 6-12. Although the affected code is present in shipped packages, the…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.4 for RHEL 7 | ansiblerole-insights-client-0:1.5-1.el7sat | RHSA-2018:2927 |
Frequently Asked Questions
Is CVE-2017-10689 in your dependencies?
Find it across RubyGems, including transitive dependencies.