CVE-2011-3870 — puppet
Fix: puppetlabs/puppet@88512e8CVE-2011-3870 is a CWE-59 vulnerability in puppet. A fix is available for puppet — see the affected versions and patch details below.
Puppet allows local users to modify the permissions of arbitrary files
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
puppet💎puppetReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to modify the permissions of arbitrary files via a symlink attack on the SSH authorized_keys file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | puppet | ≥ 2.7.0&&< 2.7.5 | 2.7.5bundle update puppet --conservative |
| 💎RubyGems | puppet | all versions | 2.6.11bundle update puppet --conservative |
Affected Products
puppetpuppetpuppetpuppetlabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for puppet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update puppet to 2.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-3870 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2011-3870 in your dependencies?
Find it across RubyGems, including transitive dependencies.