CVE-2016-2785 is a critical-severity (CVSS 9.8) CWE-284 vulnerability in puppet. A fix is available for puppet — see the affected versions and patch details below.
Puppet Improper Access Control
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
puppetReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet Agent before 1.4.2 might allow remote attackers to bypass intended auth.conf access restrictions by leveraging incorrect URL decoding.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | puppet | ≥ 4.0.0&&< 4.4.2 | 4.4.2bundle update puppet --conservative |
Affected Products
puppetpuppetpuppet agentpuppetpuppet serverpuppetDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for puppet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update puppet to 4.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2785 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2016-2785 in your dependencies?
Find it across RubyGems, including transitive dependencies.