NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2012-1987 — puppet

Fix: puppetlabs/puppet@0d6d299

CVE-2012-1987 is a security vulnerability in puppet. A fix is available for puppet — see the affected versions and patch details below.

Puppet Denial of Service and Arbitrary File Write

Also known asGHSA-v58w-6xc2-w799
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.23%1.18%2.14%3.09%0.8%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
💎puppet💎puppet

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys to (1) cause a denial of service (memory consumption) via a REST request to a stream that triggers a thread block, as demonstrated using CVE-2012-1986 and /dev/random; or (2) cause a denial of service (filesystem consumption) via crafted REST requests that use "a marshaled form of a Puppet::FileBucket::File object" to write to arbitrary file locations.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspuppet≥ 2.6.0&&< 2.6.152.6.15bundle update puppet --conservative
💎RubyGemspuppet≥ 2.7.0&&< 2.7.132.7.13bundle update puppet --conservative

Affected Products

2 products · 3 configurations
Application
puppetpuppet
≥ 2.7.0 && < 2.7.13
range
Application
puppet enterprisepuppet
≥ 1.0 && < 2.5.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for puppet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update puppet to 2.6.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-1987 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
CloudForms for RHEL 6converge-ui-devel-0:1.0.4-1.el6cfRHSA-2012:1542

Frequently Asked Questions

Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys to (1) cause a denial of service (memory consumption) via a REST request to a stream that triggers a thread block, as demonstrated using CVE-2012-1986 and /dev/random; or (2) cause a denial of service (filesystem consumption) via crafted REST requests that use "a marshaled form of a Puppet::FileBucket::File object" to write to arbitrary file locations.
O3 Security · Impact-Aware SCA

Is CVE-2012-1987 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2012-1987: puppet DoS — Fixed in 2.6.15