CVE-2011-0528 — puppet
Fix: puppetlabs/puppet@eee1a9cCVE-2011-0528 is a CWE-264 vulnerability in puppet. A fix is available for puppet — see the affected versions and patch details below.
Puppet does not properly restrict access to node resources
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
puppetReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | puppet | ≥ 2.6.0&&< 2.6.4 | 2.6.4bundle update puppet --conservative |
Affected Products
puppetpuppetDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for puppet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update puppet to 2.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-0528 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2011-0528 in your dependencies?
Find it across RubyGems, including transitive dependencies.