NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2012-1988 — puppet

Fix: puppetlabs/puppet@0d6d299

CVE-2012-1988 is a OS Command Injection vulnerability in puppet. A fix is available for puppet — see the affected versions and patch details below.

Puppet Arbitrary Command Execution

Also known asGHSA-6xxq-j39w-g3f6
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%1.09%2.18%3.27%0.5%2.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
💎puppet💎puppet

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys and file-creation permissions on the puppet master to execute arbitrary commands by creating a file whose full pathname contains shell metacharacters, then performing a filebucket request.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspuppet≥ 2.6.0&&< 2.6.152.6.15bundle update puppet --conservative
💎RubyGemspuppet≥ 2.7.0&&< 2.7.132.7.13bundle update puppet --conservative

Affected Products

5 products · 13 configurations
OS
ubuntu linuxcanonical
3 versions
10.0411.0411.10
OS
debian linuxdebian
2 versions
6.07.0
OS
fedorafedoraproject
3 versions
151617
Application
puppetpuppet
≥ 2.7.0 && < 2.7.13
range
Application
puppet enterprisepuppet
≥ 1.2.0 && < 2.5.1
2 versions
1.01.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for puppet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update puppet to 2.6.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-1988 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
CloudForms for RHEL 6converge-ui-devel-0:1.0.4-1.el6cfRHSA-2012:1542

Frequently Asked Questions

Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys and file-creation permissions on the puppet master to execute arbitrary commands by creating a file whose full pathname contains shell metacharacters, then performing a filebucket request.
O3 Security · Impact-Aware SCA

Is CVE-2012-1988 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2012-1988: puppet — Fixed in 2.6.15