NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2016-9243 — cryptography

HIGHFix: pyca/cryptography@b924696

CVE-2016-9243 is a high-severity (CVSS 7.5) vulnerability in cryptography. A fix is available for cryptography — see the affected versions and patch details below.

Improper input validation in cryptography

Also known asGHSA-q3cj-2r34-2cwcPYSEC-2017-8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
1.11%2.07%3.04%4.01%1.7%3.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍cryptography

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

HKDF in cryptography before 1.5.2 returns an empty byte-string if used with a length less than algorithm.digest_size.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcryptographyall versions1.5.3pip install --upgrade 'cryptography==1.5.3'

Affected Products

3 products · 6 configurations
OS
ubuntu linuxcanonical
2 versions
16.0416.10
Application
cryptographycryptography.io
≤ 1.5.2
range
OS
fedorafedoraproject
3 versions
232425

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cryptography, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cryptography to 1.5.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9243 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

HKDF in cryptography before 1.5.2 returns an empty byte-string if used with a length less than algorithm.digest_size.
O3 Security · Impact-Aware SCA

Is CVE-2016-9243 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-9243: cryptography — Fixed in 1.5.3