NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2026-26007 — cryptography

Fix: pyca/cryptography@0eebb9d

CVE-2026-26007 is a CWE-345 vulnerability in cryptography. A fix is available for cryptography — see the affected versions and patch details below.

cryptography Subgroup Attack Due to Missing Subgroup Validation for SECT Curves

Also known asGHSA-r6ph-v2qm-q3c2PYSEC-2026-2141
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-26007.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.30%0.59%0.89%0.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍cryptography

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Prior to 46.0.5, the public_key_from_numbers (or EllipticCurvePublicNumbers.public_key()), EllipticCurvePublicNumbers.public_key(), load_der_public_key() and load_pem_public_key() functions do not verify that the point belongs to the expected prime-order subgroup of the curve. This missing validation allows an attacker to provide a public key point P from a small-order subgroup. This can lead to security issues in various situations, such as the most commonly used signature verification (ECDSA) and shared key negotiation (ECDH). When the victim computes the shared secret as S = [victim_private_key]P via ECDH, this leaks information about victim_private_key mod (small_subgroup_order). For curves with cofactor > 1, this reveals the least significant bits of the private key. When these weak public keys are used in ECDSA , it's easy to forge signatures on the small subgroup. Only SECT curves are impacted by this. This vulnerability is fixed in 46.0.5.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcryptographyall versions46.0.5pip install --upgrade 'cryptography==46.0.5'

Affected Products

1 product · 1 configurations
Application
cryptographycryptography.io
< 46.0.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cryptography, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cryptography to 46.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-26007 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This flaw, while difficult to exploit, would lead to a loss of integrity in the encrypted communication channel. Given that the cryptography package is a library, it is likely to be used in situations that do not require user interaction.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2026-26007 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Ansible Automation Platform 2.5 for RHEL 8automation-controller-0:4.6.28-3.el8apRHSA-2026:13512
Red Hat Enterprise Linux 8fence-agents-0:4.2.1-129.el8_10.25RHSA-2026:12176
Red Hat Enterprise Linux 9fence-agents-0:4.10.0-98.el9_7.12RHSA-2026:13672
Red Hat Enterprise Linux 9fence-agents-0:4.10.0-110.el9_8.2RHSA-2026:19355
Red Hat Enterprise Linux 9.2 Update Services for SAP Solutionsfence-agents-0:4.10.0-43.el9_2.21RHSA-2026:22330
Red Hat Enterprise Linux 9.4 Extended Update Supportfence-agents-0:4.10.0-62.el9_4.24RHSA-2026:21517
Red Hat Enterprise Linux 9.6 Extended Update Supportfence-agents-0:4.10.0-86.el9_6.16RHSA-2026:21431
Red Hat Ansible Automation Platform 2.5ansible-automation-platform-25/lightspeed-rhel8:1777403872RHSA-2026:13553

Frequently Asked Questions

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Prior to 46.0.5, the public_key_from_numbers (or EllipticCurvePublicNumbers.public_key()), EllipticCurvePublicNumbers.public_key(), load_der_public_key() and load_pem_public_key() functions do not verify that the point belongs to the expected prime-order subgroup of the curve. This missing validation allows an attacker to provide a public key point P from a small-order subgroup. This can lead to security issues in various situations, such as the most commonly used signature verification (ECD
O3 Security · Impact-Aware SCA

Is CVE-2026-26007 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2026-26007: cryptography — Fixed in 46.0.5