CVE-2024-12797 is a high-severity (CVSS 7.4) CWE-392 vulnerability in cryptography. A fix is available for cryptography — see the affected versions and patch details below.
RFC7250 handshakes with unauthenticated servers don't abort as expected
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-12797.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cryptographyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Issue summary: Clients using RFC7250 Raw Public Keys (RPKs) to authenticate a server may fail to notice that the server was not authenticated, because handshakes don't abort as expected when the SSL_VERIFY_PEER verification mode is set.
Impact summary: TLS and DTLS connections using raw public keys may be vulnerable to man-in-middle attacks when server authentication failure is not detected by clients.
RPKs are disabled by default in both TLS clients and TLS servers. The issue only arises when TLS clients explicitly enable RPK use by the server, and the server, likewise, enables sending of an RPK instead of an X.509 certificate chain. The affected clients are those that then rely on the handshake to fail when the server's RPK fails to match one of the expected public keys, by setting the verification mode to SSL_VERIFY_PEER.
Clients that enable server-side raw public keys can still find out that raw public key verification failed by calling SSL_get_verify_result(), and those that do, and take appropriate action, are not affected. This issue was introduced in the initial implementation of RPK support in OpenSSL 3.2.
The FIPS modules in 3.4, 3.3, 3.2, 3.1 and 3.0 are not affected by this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | cryptography | ≥ 42.0.0&&< 44.0.1 | 44.0.1pip install --upgrade 'cryptography==44.0.1' |
Affected Products
bootstrap osnetappbrocade fabric operating systemnetapph300s firmwarenetapph410c firmwarenetapph410s firmwarenetapph500s firmwarenetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cryptography, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cryptography to 44.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-12797 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue was introduced in the initial implementation of RPK support in OpenSSL 3.2, which was first shipped in RHEL 9.5. Earlier releases of OpenSSL provided in RHEL prior to 9.5 are not affected. RPKs are disabled by default in both TLS clients and TLS servers. The issue only arises when TLS clients explicitly…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-12797 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Discovery 1 for RHEL 9 | discovery/discovery-server-rhel9:1.12.1-2 | RHSA-2025:1487 |
| Red Hat Enterprise Linux 10 | openssl-1:3.2.2-16.el10 | RHBA-2025:6314 |
| Red Hat Enterprise Linux 9 | openssl-1:3.2.2-6.el9_5.1 | RHSA-2025:1330 |
| RHOL-5.9-RHEL-9 | openshift-logging/cluster-logging-operator-bundle:v5.9.12-13 | RHSA-2025:1985 |
| Service Interconnect 1.4 for RHEL 9 | service-interconnect/skupper-config-sync-rhel9:1.4.8-1 | RHSA-2025:9895 |
| Service Interconnect 1 for RHEL 9 | service-interconnect/skupper-config-sync-rhel9:1.5.5-5 | RHSA-2025:1925 |
| Service Interconnect 1 for RHEL 9 | service-interconnect/skupper-config-sync-rhel9:1.8.5-1 | RHSA-2025:4005 |
| Builds for Red Hat OpenShift 1.3.2 | openshift-builds/openshift-builds-git-cloner-rhel9:1.3.1-1741784043 | RHSA-2025:2754 |
Frequently Asked Questions
Is CVE-2024-12797 in your dependencies?
Find it across PyPI, including transitive dependencies.