CVE-2016-6816 is a high-severity (CVSS 7.1) Improper Input Validation vulnerability in org.apache.tomcat:tomcat-coyote. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat-coyote — see the affected versions and patch details below.
Improper Input Validation in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2016-6816.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyoteReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The code in Apache Tomcat 9.0.0.M1 to 9.0.0.M11, 8.5.0 to 8.5.6, 8.0.0.RC1 to 8.0.38, 7.0.0 to 7.0.72, and 6.0.0 to 6.0.47 that parsed the HTTP request line permitted invalid characters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack and/or obtain sensitive information from requests other then their own.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 9.0.0.M1&&< 9.0.0.M12 | 9.0.0.M12org.apache.tomcat:tomcat-coyote:9.0.0.M12 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 8.5.0&&< 8.5.8 | 8.5.8org.apache.tomcat:tomcat-coyote:8.5.8 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 8.0.0RC1&&< 8.0.39 | 8.0.39org.apache.tomcat:tomcat-coyote:8.0.39 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 7.0.0&&< 7.0.73 | 7.0.73org.apache.tomcat:tomcat-coyote:7.0.73 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 6.0.0&&< 6.0.48 | 6.0.48org.apache.tomcat:tomcat-coyote:6.0.48 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Tomcat 6/7/8/9 - Information Disclosure
by justpentest · Apr 4, 2017
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-coyote to 9.0.0.M12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6816 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Applying the fix provided to mitigate this issue may cause Tomcat to return 400 status after updating. For more information, refer to https://access.redhat.com/solutions/2891171
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-105.el6_8 | RHSA-2017:0527 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.69-11.el7_3 | RHSA-2017:0935 |
| Red Hat JBoss Enterprise Application Platform 6.4 | see advisory | RHSA-2017:0247 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5 | apache-cxf-0:2.7.18-5.SP4_redhat_1.1.ep6.el5 | RHSA-2017:0246 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | apache-cxf-0:2.7.18-5.SP4_redhat_1.1.ep6.el6 | RHSA-2017:0244 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | jboss-ec2-eap-0:7.5.13-1.Final_redhat_2.ep6.el6 | RHSA-2017:0250 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 | apache-cxf-0:2.7.18-5.SP4_redhat_1.1.ep6.el7 | RHSA-2017:0245 |
| Red Hat JBoss Web Server 3.1 | see advisory | RHSA-2017:0457 |
Frequently Asked Questions
Is CVE-2016-6816 in your dependencies?
Find it across Maven, including transitive dependencies.