CVE-2016-4433 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in org.apache.struts.xwork:xwork-core. A fix is available for org.apache.struts.xwork:xwork-core — see the affected versions and patch details below.
Apache Struts Open Redirect
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.struts.xwork:xwork-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Struts 2 2.3.20 through 2.3.28.1 allows remote attackers to bypass intended access restrictions and conduct redirection attacks via a crafted request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.struts.xwork:xwork-core | ≥ 2.3.20&&< 2.3.29 | 2.3.29org.apache.struts.xwork:xwork-core:2.3.29 |
Affected Products
strutsapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts.xwork:xwork-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.struts.xwork:xwork-core to 2.3.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4433 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2016-4433 in your dependencies?
Find it across Maven, including transitive dependencies.