NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2013-1966 — struts2-core

Fix: apache/struts@7e6f641

CVE-2013-1966 is a Code Injection vulnerability in org.apache.struts:struts2-core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.struts:struts2-core — see the affected versions and patch details below.

Arbitrary code execution in Apache Struts

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
73.7%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
66.0%76.3%86.6%96.9%91.1%73.7%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.apache.struts:struts2-core☕org.apache.struts.xwork:xwork-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.struts:struts2-core≥ 2.0.0&&< 2.3.14.22.3.14.2org.apache.struts:struts2-core:2.3.14.2
☕Mavenorg.apache.struts.xwork:xwork-core≥ 2.0.0&&< 2.3.14.22.3.14.2org.apache.struts.xwork:xwork-core:2.3.14.2

Affected Products

1 product · 1 configurations
Application
strutsapache
≥ 2.0.0 && < 2.3.14.1
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-25980remotemultiple✓ Verified

Apache Struts - includeParams Remote Code Execution (Metasploit)

by Metasploit · Jun 5, 2013

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.struts:struts2-core to 2.3.14.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-1966 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag.
O3 Security · Impact-Aware SCA

Is CVE-2013-1966 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2013-1966: struts2-core — Fixed in 2.3.14.2