NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2013-2134 — struts2-core

Fix: apache/struts@01e6b25

CVE-2013-2134 is a Code Injection vulnerability in org.apache.struts:struts2-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.struts:struts2-core — see the affected versions and patch details below.

Arbitrary code execution in Apache Struts 2

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
70.2%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
63.8%75.2%86.6%97.9%91.5%70.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.apache.struts:struts2-core☕org.apache.struts.xwork:xwork-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.struts:struts2-core≥ 2.0.0&&< 2.3.14.32.3.14.3org.apache.struts:struts2-core:2.3.14.3
☕Mavenorg.apache.struts.xwork:xwork-core≥ 2.0.0&&< 2.3.14.32.3.14.3org.apache.struts.xwork:xwork-core:2.3.14.3

Affected Products

1 product · 1 configurations
Application
strutsapache
≥ 2.0.0 && < 2.3.14.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-38549remotemultiple✓ Verified

Apache Struts - OGNL Expression Injection

by Jon Passki · Jun 5, 2013

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.struts:struts2-core to 2.3.14.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2134 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.
O3 Security · Impact-Aware SCA

Is CVE-2013-2134 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2013-2134: struts2-core — Fixed in 2.3.14.3