NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2012-0838 — struts2-core

Fix: apache/struts@25e5006

CVE-2012-0838 is a Improper Input Validation vulnerability in org.apache.struts:struts2-core. EPSS puts its 30-day exploitation probability at 13.7% (96th percentile). A fix is available for org.apache.struts:struts2-core — see the affected versions and patch details below.

Apache Struts Code injection due to conversion error

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
13.7%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
10.2%11.8%13.3%14.9%11.1%13.7%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.apache.struts:struts2-core☕org.apache.struts.xwork:xwork-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Struts 2 before 2.2.3.1 evaluates a string as an OGNL expression during the handling of a conversion error, which allows remote attackers to modify run-time data values, and consequently execute arbitrary code, via invalid input to a field.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.struts:struts2-coreall versions2.2.3.1org.apache.struts:struts2-core:2.2.3.1
☕Mavenorg.apache.struts.xwork:xwork-coreall versions2.2.3.1org.apache.struts.xwork:xwork-core:2.2.3.1

Affected Products

1 product · 1 configurations
Application
strutsapache
≥ 2.0.0 && ≤ 2.2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.struts:struts2-core to 2.2.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-0838 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Apache Struts 2 before 2.2.3.1 evaluates a string as an OGNL expression during the handling of a conversion error, which allows remote attackers to modify run-time data values, and consequently execute arbitrary code, via invalid input to a field.
O3 Security · Impact-Aware SCA

Is CVE-2012-0838 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2012-0838: struts2-core RCE — Fixed in 2.2.3.1