NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2016-3109 — shopware

CRITICALFix: shopware/shopware@d73e903

CVE-2016-3109 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in shopware/shopware. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for shopware/shopware — see the affected versions and patch details below.

Shopware RCE Vulnerability

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
28.1%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
27.4%28.0%28.5%29.1%28.6%28.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘shopware/shopware🐘shopware/shopware

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistshopware/shopwareall versions4.3.7composer require shopware/shopware:^4.3.7
🐘Packagistshopware/shopware≥ 5.0.0&&< 5.1.55.1.5composer require shopware/shopware:^5.1.5

Affected Products

1 product · 1 configurations
Application
shopwareshopware
≤ 5.1.4
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/shopware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update shopware/shopware to 4.3.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3109 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The `backend/Login/load/` script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
O3 Security · Impact-Aware SCA

Is CVE-2016-3109 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-3109: shopware RCE — Fixed in 4.3.7