CVE-2014-2853 — core
Fix: wikimedia/mediawiki-core@0b695aeCVE-2014-2853 is a Cross-site Scripting (XSS) vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.
Cross-site scripting vulnerability in includes/actions/InfoAction.php
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in includes/actions/InfoAction.php in MediaWiki before 1.21.9 and 1.22.x before 1.22.6 allows remote attackers to inject arbitrary web script or HTML via the sort key in an info action.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | all versions | 1.21.9composer require mediawiki/core:^1.21.9 |
| 🐘Packagist | mediawiki/core | ≥ 1.22.0&&< 1.22.6 | 1.22.6composer require mediawiki/core:^1.22.6 |
Affected Products
mediawikimediawikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.21.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-2853 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2014-2853 in your dependencies?
Find it across Packagist, including transitive dependencies.