CVE-2014-0193 — netty
Fix: netty/netty@8599ab5CVE-2014-0193 is a CWE-399 vulnerability in io.netty:netty. A fix is available for io.netty:netty — see the affected versions and patch details below.
Netty denial of service vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
io.netty:netty☕io.netty:netty☕io.netty:netty☕io.netty:netty☕io.netty:netty☕io.netty:netty-allReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
WebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a TextWebSocketFrame followed by a long stream of ContinuationWebSocketFrames.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.netty:netty | ≥ 3.6.0.Beta1&&< 3.6.9.Final | 3.6.9.Finalio.netty:netty:3.6.9.Final |
| ☕Maven | io.netty:netty | ≥ 3.7.0.Final&&< 3.7.1.Final | 3.7.1.Finalio.netty:netty:3.7.1.Final |
| ☕Maven | io.netty:netty | ≥ 3.8.0.Final&&< 3.8.2.Final | 3.8.2.Finalio.netty:netty:3.8.2.Final |
| ☕Maven | io.netty:netty | ≥ 3.9.0.Final&&< 3.9.1.Final | 3.9.1.Finalio.netty:netty:3.9.1.Final |
| ☕Maven | io.netty:netty | ≥ 4.0.0.Alpha1&&< 4.0.19.Final | 4.0.19.Finalio.netty:netty:4.0.19.Final |
| ☕Maven | io.netty:netty-all | ≥ 4.0.0.Alpha1&&< 4.0.19.Final | 4.0.19.Finalio.netty:netty-all:4.0.19.Final |
Affected Products
nettynettyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.netty:netty, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.netty:netty to 3.6.9.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0193 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.1 | see advisory | RHSA-2014:1351 |
| Red Hat JBoss BPMS 6.0 | netty | RHSA-2015:0234 |
| Red Hat JBoss BRMS 6.0 | netty | RHSA-2014:0818 |
| Red Hat JBoss BRMS 6.0 | netty | RHSA-2015:0235 |
| Red Hat JBoss Data Virtualization 6.0 | netty | RHSA-2015:0765 |
| Red Hat JBoss Data Virtualization 6.1 | see advisory | RHSA-2015:0675 |
| Red Hat JBoss Enterprise Application Platform 6.3 | netty | RHSA-2014:1021 |
| Red Hat JBoss Enterprise Application Platform 6 for RHEL 5 | apache-commons-beanutils-eap6-0:1.8.3-7.redhat_6.1.ep6.el5 | RHSA-2014:1019 |
Frequently Asked Questions
Is CVE-2014-0193 in your dependencies?
Find it across Maven, including transitive dependencies.