CVE-2021-43797 is a medium-severity (CVSS 6.5) CWE-444 vulnerability in io.netty:netty-codec-http. A fix is available for io.netty:netty-codec-http — see the affected versions and patch details below.
HTTP request smuggling in netty
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.netty:netty-codec-http☕org.jboss.netty:netty☕io.netty:nettyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. Netty prior to version 4.1.71.Final skips control chars when they are present at the beginning / end of the header name. It should instead fail fast as these are not allowed by the spec and could lead to HTTP request smuggling. Failing to do the validation might cause netty to "sanitize" header names before it forward these to another remote system when used as proxy. This remote system can't see the invalid usage anymore, and therefore does not do the validation itself. Users should upgrade to version 4.1.71.Final.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.netty:netty-codec-http | ≥ 4.0.0&&< 4.1.71.Final | 4.1.71.Finalio.netty:netty-codec-http:4.1.71.Final |
| ☕Maven | org.jboss.netty:netty | all versions | No fix |
| ☕Maven | io.netty:netty | all versions | No fix |
Affected Products
debian linuxdebianoncommand workflow automationnetappsnapcenternetappnettynettybanking deposits and lines of credit servicingoraclebanking party managementoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.netty:netty-codec-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.netty:netty-codec-http to 4.1.71.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-43797 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In OpenShift Container Platform (OCP), the Hive/Presto/Hadoop components that comprise the OCP Metering stack, ship the vulnerable version of netty-codec-http package. Since the release of OCP 4.6, the Metering product has been deprecated, hence the affected components are marked as wontfix. The…
| Product | Fixed in | Advisory |
|---|---|---|
| Logging subsystem for Red Hat OpenShift 5.4 | openshift-logging/elasticsearch6-rhel8:v6.8.1-156 | RHSA-2022:2216 |
| OpenShift Logging 5.2 | openshift-logging/elasticsearch6-rhel8:v6.8.1-157 | RHSA-2022:2218 |
| OpenShift Logging 5.3 | openshift-logging/elasticsearch6-rhel8:v6.8.1-159 | RHSA-2022:2217 |
| Red Hat AMQ 7.10.0 | netty | RHSA-2022:5101 |
| Red Hat AMQ Streams 2.1.0 | netty | RHSA-2022:1345 |
| Red Hat build of Quarkus 2.7.5 | netty | RHSA-2022:4623 |
| Red Hat Data Grid 8.3.0 | netty | RHSA-2022:0520 |
| Red Hat Fuse 7.11 | netty | RHSA-2022:5532 |
Frequently Asked Questions
Is CVE-2021-43797 in your dependencies?
Find it across Maven, including transitive dependencies.