CVE-2021-21409 is a medium-severity (CVSS 5.9) CWE-444 vulnerability in io.netty:netty-codec-http2. A fix is available for io.netty:netty-codec-http2 — see the affected versions and patch details below.
Possible request smuggling in HTTP/2 due missing validation of content-length
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.netty:netty-codec-http2☕org.jboss.netty:netty☕io.netty:nettyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.61.Final there is a vulnerability that enables request smuggling. The content-length header is not correctly validated if the request only uses a single Http2HeaderFrame with the endStream set to to true. This could lead to request smuggling if the request is proxied to a remote peer and translated to HTTP/1.1. This is a followup of GHSA-wm47-8v5p-wjpj/CVE-2021-21295 which did miss to fix this one case. This was fixed as part of 4.1.61.Final.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.netty:netty-codec-http2 | ≥ 4.0.0&&< 4.1.61.Final | 4.1.61.Finalio.netty:netty-codec-http2:4.1.61.Final |
| ☕Maven | org.jboss.netty:netty | all versions | No fix |
| ☕Maven | io.netty:netty | all versions | No fix |
Affected Products
debian linuxdebianoncommand api servicesnetapponcommand workflow automationnetappnettynettybanking corporate lending process managementoraclebanking credit facilities process managementoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.netty:netty-codec-http2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.netty:netty-codec-http2 to 4.1.61.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21409 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Satellite ships a vulnerable Netty version embedded in Candlepin. However, it is not directly vulnerable since the HTTP requests are handled by Tomcat and not by Netty. Red Hat OpenStack Platform's OpenDaylight will not be updated for this flaw because it was deprecated as of OpenStack Platform 14 and is only…
| Product | Fixed in | Advisory |
|---|---|---|
| AMQ Clients 2.y for RHEL 7 | qpid-proton-0:0.33.0-6.el7_9 | RHSA-2021:1511 |
| EAP 7.3.8 | netty | RHSA-2021:2696 |
| OpenShift Logging 5.1 | openshift-logging/elasticsearch6-rhel8:v6.8.1-67 | RHSA-2021:5128 |
| OpenShift Logging 5.2 | openshift-logging/elasticsearch6-rhel8:v6.8.1-66 | RHSA-2021:5127 |
| OpenShift Logging 5.3 | openshift-logging/elasticsearch6-rhel8:v6.8.1-65 | RHSA-2021:5129 |
| Red Hat AMQ 7.8.2 | netty | RHSA-2021:2689 |
| Red Hat AMQ 7.9.0 | see advisory | RHSA-2021:3700 |
| Red Hat AMQ Streams 1.8.0 | netty | RHSA-2021:3225 |
Frequently Asked Questions
Is CVE-2021-21409 in your dependencies?
Find it across Maven, including transitive dependencies.