CVE-2026-50560 — netty-codec-http2
CVE-2026-50560 is a CWE-770 vulnerability in io.netty:netty-codec-http2. A fix is available for io.netty:netty-codec-http2 — see the affected versions and patch details below.
Netty susceptible to HTTP/2 Reset Attack with different on-the-wire signature
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-50560.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
io.netty:netty-codec-http2☕io.netty:netty-codec-http2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Netty HTTP/2 max header size handling produces attack similar to HTTP/2 Rapid Reset.
Details
There is a setting in the http2 specification called SETTINGS_MAX_HEADER_LIST_SIZE. According to the RFC: “This advisory setting informs a peer of the maximum field section size that the sender is prepared to accept, in units of octets.”
When a client sends that setting to Netty, it appears that Netty will behave as follows:
- Read the request
- Proxy the request to the origin
- Attempt to produce a response
- Create an exception while writing the headers for the response
Functionally, this should be similar to the http2 reset attack, but with a different on-the-wire signature.
Remediation
When speaking with clients, Netty should potentially treat this as “advisory” and ignore it. It would be best to ignore the SETTINGS_MAX_HEADER_LIST_SIZE setting from clients (or ignore it when sending to clients). According to the spec, a server does not need to honor this advisory setting, and it appears that other http/2 implementations ignore it when acting as a server.
Impact
This is a DDoS attack similar to the HTTP/2 Rapid Reset Attack.
Credit
Jonathan Looney (Engineering, Netflix)
Contact
Ashley Tolbert (Security, Netflix) - [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.netty:netty-codec-http2 | ≥ 4.2.0.Final&&< 4.2.15.Final | 4.2.15.Finalio.netty:netty-codec-http2:4.2.15.Final |
| ☕Maven | io.netty:netty-codec-http2 | all versions | 4.1.135.Finalio.netty:netty-codec-http2:4.1.135.Final |
Affected Products
nettynettyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.netty:netty-codec-http2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.netty:netty-codec-http2 to 4.2.15.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-50560 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This flaw in Netty's HTTP/2 protocol handling is rated Moderate. A remote, unauthenticated attacker can trigger a denial of service by sending a crafted `SETTINGS_MAX_HEADER_LIST_SIZE` frame, causing an exception during response header processing. This can disrupt services utilizing Netty for HTTP/2 communication.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-50560 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat build of Quarkus 3.27.4.SP1 | io.netty/netty-codec-http2:4.1.135.Final-redhat-00001 | RHSA-2026:26018 |
| Red Hat build of Quarkus 3.33.2.SP1 | io.netty/netty-codec-http2:4.1.135.Final-redhat-00001 | RHSA-2026:26017 |
Frequently Asked Questions
Is CVE-2026-50560 in your dependencies?
Find it across Maven, including transitive dependencies.