NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2019-20444 — netty-codec-http

CRITICALFix: netty/netty#9871

CVE-2019-20444 is a critical-severity (CVSS 9.1) CWE-444 vulnerability in io.netty:netty-codec-http. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for io.netty:netty-codec-http — see the affected versions and patch details below.

HTTP Request Smuggling in Netty

Also known asGHSA-cqqj-4p63-rrmm
Published
Updated
Affected
3 pkgs
Patched
1 / 3
Exploits
1 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
6.09%11.1%16.1%21.1%11.9%8.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕io.netty:netty-codec-http☕org.jboss.netty:netty☕io.netty:netty

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

HttpObjectDecoder.java in Netty before 4.1.44 allows an HTTP header that lacks a colon, which might be interpreted as a separate header with an incorrect syntax, or might be interpreted as an "invalid fold."

Affected Packages

3 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.netty:netty-codec-httpall versions4.1.44io.netty:netty-codec-http:4.1.44
☕Mavenorg.jboss.netty:nettyall versionsNo fix
☕Mavenio.netty:nettyall versionsNo fix

Affected Products

6 products · 9 configurations
OS
ubuntu linuxcanonical
1 version
18.04
OS
debian linuxdebian
3 versions
8.09.010.0
OS
fedorafedoraproject
1 version
33
Application
nettynetty
< 4.1.44
range
Application
jboss amq clientsredhat
1 version
2
Application
jboss enterprise application platformredhat
2 versions
7.27.3
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.netty:netty-codec-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.netty:netty-codec-http to 4.1.44 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-20444 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

OpenShift Container Platform ships a vulnerable netty library as part of the logging-elasticsearch5 container. ElasticSearch's security team has stated that the previous vulnerability, CVE-2019-16869, does not pose a substantial practical threat to ElasticSearch 6. We agree that these issues would be difficult to…

Workaround published by Red Hat
* Use HTTP/2 instead (clear boundaries between requests) * Disable reuse of backend connections eg. ```http-reuse never``` in HAProxy or whatever equivalent LB settings
Source: Red Hat security advisory for CVE-2019-20444 (CC BY 4.0)
ProductFixed inAdvisory
AMQ Clients 2.y for RHEL 6qpid-proton-0:0.30.0-4.el6_10RHSA-2020:0601
EAP-CD 19 Tech PreviewnettyRHSA-2020:2333
Red Hat AMQnettyRHSA-2020:0922
Red Hat AMQ 7.4.3nettyRHSA-2020:1445
Red Hat AMQ Online 1.3.3 GAnettyRHSA-2020:0497
Red Hat AMQ Streams 1nettyRHSA-2020:0939
Red Hat Data Grid 7.3.6nettyRHSA-2020:2321
Red Hat Decision Manager 7nettyRHSA-2020:3196

Frequently Asked Questions

HttpObjectDecoder.java in Netty before 4.1.44 allows an HTTP header that lacks a colon, which might be interpreted as a separate header with an incorrect syntax, or might be interpreted as an "invalid fold."
O3 Security · Impact-Aware SCA

Is CVE-2019-20444 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-20444: netty-codec-http — Fixed in 4.1.44