CVE-2015-2156 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in io.netty:netty-parent. A fix is available for io.netty:netty-parent — see the affected versions and patch details below.
Information Exposure in Netty
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.netty:netty-parent☕org.jboss.netty:netty☕org.jboss.netty:netty☕io.netty:netty☕io.netty:nettyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Netty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before 4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before 2.3.9 might allow remote attackers to bypass the httpOnly flag on cookies and obtain sensitive information by leveraging improper validation of cookie name and value characters.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.netty:netty-parent | ≥ 4.0.0&&< 4.0.28.Final | 4.0.28.Finalio.netty:netty-parent:4.0.28.Final |
| ☕Maven | org.jboss.netty:netty | all versions | 3.9.8.Finalorg.jboss.netty:netty:3.9.8.Final |
| ☕Maven | org.jboss.netty:netty | ≥ 3.10.0&&< 3.10.3.Final | 3.10.3.Finalorg.jboss.netty:netty:3.10.3.Final |
| ☕Maven | io.netty:netty | ≥ 3.10.0&&< 3.10.3.Final | 3.10.3.Finalio.netty:netty:3.10.3.Final |
| ☕Maven | io.netty:netty | all versions | 3.9.8.Finalio.netty:netty:3.9.8.Final |
Affected Products
play frameworklightbendnettynettyplay frameworkplayframeworkDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.netty:netty-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.netty:netty-parent to 4.0.28.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-2156 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2015-2156 in your dependencies?
Find it across Maven, including transitive dependencies.