NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2012-6133 — roundup

MEDIUM

CVE-2012-6133 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in roundup. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for roundup — see the affected versions and patch details below.

Multiple cross-site scripting (XSS) vulnerabilities in Roundup

Also known asPYSEC-2020-212
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.69%1.37%2.06%0.5%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍roundup

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in Roundup before 1.4.20 allow remote attackers to inject arbitrary web script or HTML via the (1) @ok_message or (2) @error_message parameter to issue*.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIroundupall versions1.4.20pip install --upgrade 'roundup==1.4.20'

Affected Products

1 product · 1 configurations
Application
rounduproundup-tracker
< 1.4.20
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for roundup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update roundup to 1.4.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-6133 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in Roundup before 1.4.20 allow remote attackers to inject arbitrary web script or HTML via the (1) @ok_message or (2) @error_message parameter to issue*.
O3 Security · Impact-Aware SCA

Is CVE-2012-6133 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2012-6133: roundup XSS — Fixed in 1.4.20