NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2010-2491 — roundup

MEDIUMFix: roundup-tracker/roundup@dcef024

CVE-2010-2491 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in roundup. A fix is available for roundup — see the affected versions and patch details below.

Roundup Cross-site Scripting (XSS) vulnerability

Also known asPYSEC-2010-31
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.17%1.15%2.12%3.10%0.7%2.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍roundup

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in cgi/client.py in Roundup before 1.4.14 allows remote attackers to inject arbitrary web script or HTML via the template argument to the /issue program.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIroundupall versions1.4.14pip install --upgrade 'roundup==1.4.14'

Affected Products

1 product · 104 configurations
Application
rounduproundup-tracker
≤ 1.4.13
85 versions
0.1.00.1.10.1.20.1.30.2.00.2.10.2.20.2.30.2.40.2.50.2.60.2.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for roundup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update roundup to 1.4.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-2491 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in `cgi/client.py` in Roundup before 1.4.14 allows remote attackers to inject arbitrary web script or HTML via the template argument to the /issue program.
O3 Security · Impact-Aware SCA

Is CVE-2010-2491 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2010-2491: roundup XSS — Fixed in 1.4.14