NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2012-6131 — roundup

Fix: roundup-tracker/roundup@38193cc

CVE-2012-6131 is a Cross-site Scripting (XSS) vulnerability in roundup. A fix is available for roundup — see the affected versions and patch details below.

Roundup Cross-site scripting (XSS) vulnerability

Also known asPYSEC-2014-16
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%0.83%1.67%2.50%0.4%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍roundup

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site Scripting (XSS) vulnerability in cgi/client.py in Roundup before 1.4.20 allows remote attackers to inject arbitrary web script or HTML via the @action parameter to support/issue1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIroundupall versions1.4.20pip install --upgrade 'roundup==1.4.20'

Affected Products

1 product · 20 configurations
Application
rounduproundup-tracker
≤ 1.4.19
19 versions
1.4.01.4.11.4.21.4.31.4.41.4.51.4.61.4.71.4.81.4.91.4.101.4.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for roundup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update roundup to 1.4.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-6131 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) vulnerability in `cgi/client.py` in Roundup before 1.4.20 allows remote attackers to inject arbitrary web script or HTML via the `@action` parameter to `support/issue1`.
O3 Security · Impact-Aware SCA

Is CVE-2012-6131 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2012-6131: roundup XSS — Fixed in 1.4.20