NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2025-53865 — roundup

MEDIUMFix: roundup-tracker/roundup@3b1f22f

CVE-2025-53865 is a medium-severity (CVSS 6.4) Cross-site Scripting (XSS) vulnerability in roundup. A fix is available for roundup — see the affected versions and patch details below.

Roundup is vulnerable to XSS through interactions between URLs and issue tracker templates

Also known asPYSEC-2025-69
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-53865.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs12th percentile — riskier than 12% of all scored CVEsHighest risk
0.00%0.24%0.48%0.72%0.1%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍roundup

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

In Roundup before 2.5.0, XSS can occur via interaction between URLs and issue tracker templates (devel and responsive).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIroundupall versions2.5.0pip install --upgrade 'roundup==2.5.0'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for roundup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update roundup to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-53865 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Roundup before 2.5.0, XSS can occur via interaction between URLs and issue tracker templates (devel and responsive).
O3 Security · Impact-Aware SCA

Is CVE-2025-53865 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2025-53865: roundup XSS — Fixed in 2.5.0