NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2024-39124 — roundup

MEDIUMFix: roundup-tracker/roundup@860e3c8

CVE-2024-39124 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in roundup. A fix is available for roundup — see the affected versions and patch details below.

Roundup Cross-site Scripting Vulnerability

Also known asPYSEC-2024-63
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-39124.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs22th percentile — riskier than 22% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.7%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍roundup

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIroundupall versions2.4.0pip install --upgrade 'roundup==2.4.0'

Affected Products

1 product · 1 configurations
Application
rounduproundup-tracker
< 2.4.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for roundup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update roundup to 2.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-39124 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.
O3 Security · Impact-Aware SCA

Is CVE-2024-39124 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-39124: roundup XSS — Fixed in 2.4.0