NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2010-0667 — moin

HIGH

CVE-2010-0667 is a high-severity (CVSS 7.5) Information Exposure vulnerability in moin. A fix is available for moin — see the affected versions and patch details below.

MoinMoin Exposure of Sensitive Disclosure when GATEWAY_INTERFACE variable is set

Also known asPYSEC-2010-14
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.43%1.07%1.72%2.37%0.9%1.9%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍moin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

MoinMoin 1.9 before 1.9.1 does not perform the expected clearing of the sys.argv array in situations where the GATEWAY_INTERFACE environment variable is set, which allows remote attackers to obtain sensitive information via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImoin≥ 1.9&&< 1.9.11.9.1pip install --upgrade 'moin==1.9.1'

Affected Products

1 product · 1 configurations
Application
moinmoinmoinmo
1 version
1.9.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moin to 1.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-0667 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

MoinMoin 1.9 before 1.9.1 does not perform the expected clearing of the sys.argv array in situations where the `GATEWAY_INTERFACE` environment variable is set, which allows remote attackers to obtain sensitive information via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2010-0667 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2010-0667: moin Info Disclosure — Fixed in 1.9.1