NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2008-5646 — trac

HIGH

CVE-2008-5646 is a high-severity (CVSS 7.5) vulnerability in trac. A fix is available for trac — see the affected versions and patch details below.

Trac vulnerable to denial of service

Also known asGHSA-437p-qw95-wqqrPYSEC-2008-6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.15%1.73%0.5%1.2%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍trac

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Unspecified vulnerability in Trac before 0.11.2 allows attackers to cause a denial of service via unknown attack vectors related to "certain wiki markup."

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItracall versions0.11.2pip install --upgrade 'trac==0.11.2'

Affected Products

1 product · 32 configurations
Application
tractrac
≤ 0.11.2.1
28 versions
0.50.5.10.5.20.60.6.10.70.7.10.80.8.10.8.20.8.30.8.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for trac, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update trac to 0.11.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-5646 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Unspecified vulnerability in Trac before 0.11.2 allows attackers to cause a denial of service via unknown attack vectors related to "certain wiki markup."
O3 Security · Impact-Aware SCA

Is CVE-2008-5646 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2008-5646: trac DoS — Fixed in 0.11.2