NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2008-3328 — trac

MEDIUM

CVE-2008-3328 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in trac. A fix is available for trac — see the affected versions and patch details below.

Trac Cross-site Scripting (XSS) vulnerability

Also known asGHSA-x6jf-c7wh-7m7wPYSEC-2008-5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.22%1.83%0.5%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍trac

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the wiki engine in Trac before 0.10.5 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItracall versions0.10.5pip install --upgrade 'trac==0.10.5'

Affected Products

1 product · 28 configurations
Application
tracedgewall_software
≤ 0.10.4
27 versions
0.50.5.10.5.20.60.6.10.70.7.10.80.8.10.8.20.8.30.8.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for trac, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update trac to 0.10.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-3328 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the wiki engine in Trac before 0.10.5 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.
O3 Security · Impact-Aware SCA

Is CVE-2008-3328 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2008-3328: trac XSS — Fixed in 0.10.5