CVE-2009-4405 — trac
HIGHCVE-2009-4405 is a high-severity (CVSS 7.5) vulnerability in trac. A fix is available for trac — see the affected versions and patch details below.
Trac is vulnerable to improper policy checks and missing 'raw' role check in docutils
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tracReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Multiple unspecified vulnerabilities in Trac before 0.11.6 have unknown impact and attack vectors, possibly related to (1) "policy checks in report results when using alternate formats" or (2) a "check for the 'raw' role that is missing in docutils < 0.6."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | trac | all versions | 0.11.6pip install --upgrade 'trac==0.11.6' |
Affected Products
tracedgewallDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for trac, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update trac to 0.11.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-4405 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2009-4405 in your dependencies?
Find it across PyPI, including transitive dependencies.