NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2007-1406 — trac

MEDIUM

CVE-2007-1406 is a medium-severity (CVSS 5.3) vulnerability in trac. A fix is available for trac — see the affected versions and patch details below.

Trac missing Content-Disposition HTTP header

Also known asGHSA-7jjr-3r8r-9pcfPYSEC-2007-3
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk+0.07%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.01%0.64%1.28%1.91%0.5%1.4%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍trac

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Trac before 0.10.3.1 does not send a Content-Disposition HTTP header specifying an attachment in certain "unsafe" situations, which has unknown impact and remote attack vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItracall versions0.10.3.1pip install --upgrade 'trac==0.10.3.1'

Affected Products

1 product · 4 configurations
Application
tracedgewall_software
4 versions
0.100.10.10.10.20.10.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for trac, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update trac to 0.10.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2007-1406 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Trac before 0.10.3.1 does not send a Content-Disposition HTTP header specifying an attachment in certain "unsafe" situations, which has unknown impact and remote attack vectors.
O3 Security · Impact-Aware SCA

Is CVE-2007-1406 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2007-1406: trac — Fixed in 0.10.3.1