CVE-2005-4644 — trac
MEDIUMCVE-2005-4644 is a medium-severity (CVSS 6.1) vulnerability in trac. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for trac — see the affected versions and patch details below.
Trac HTML WikiProcessor cross-site scripting (XSS) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tracReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the HTML WikiProcessor in Edgewall Trac 0.9.2 allows remote attackers to inject arbitrary web script or HTML via javascript in the SRC attribute of an IMG tag.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | trac | all versions | 0.9-stablepip install --upgrade 'trac==0.9-stable' |
Affected Products
tracedgewall_softwareResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for trac, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update trac to 0.9-stable or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2005-4644 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2005-4644 in your dependencies?
Find it across PyPI, including transitive dependencies.