CVE-2008-1475 is a critical-severity (CVSS 9.1) CWE-264 vulnerability in roundup. A fix is available for roundup — see the affected versions and patch details below.
Roundup xml-rpc server improper check of property permissions
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
roundupReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The xml-rpc server in Roundup 1.4.4 does not check property permissions, which allows attackers to bypass restrictions and edit or read restricted properties via the (1) list, (2) display, and (3) set methods.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | roundup | all versions | 1.4.5pip install --upgrade 'roundup==1.4.5' |
Affected Products
rounduproundup-trackerDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for roundup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update roundup to 1.4.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-1475 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2008-1475 in your dependencies?
Find it across PyPI, including transitive dependencies.