NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2008-1474 — roundup

MEDIUMFix: roundup-tracker/roundup@151ffd3

CVE-2008-1474 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in roundup. A fix is available for roundup — see the affected versions and patch details below.

Roundup vulnerability related to Cross-site scripting (XSS)

Also known asPYSEC-2008-9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.99%1.32%1.66%2.00%1.5%1.5%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍roundup

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Multiple unspecified vulnerabilities in Roundup before 1.4.4 have unknown impact and attack vectors, some of which may be related to cross-site scripting (XSS).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIroundupall versions1.4.4pip install --upgrade 'roundup==1.4.4'

Affected Products

1 product · 94 configurations
Application
rounduproundup-tracker
≤ 1.4.3
75 versions
0.1.00.1.10.1.20.1.30.2.00.2.10.2.20.2.30.2.40.2.50.2.60.2.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for roundup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update roundup to 1.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-1474 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple unspecified vulnerabilities in Roundup before 1.4.4 have unknown impact and attack vectors, some of which may be related to cross-site scripting (XSS).
O3 Security · Impact-Aware SCA

Is CVE-2008-1474 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2008-1474: roundup XSS — Fixed in 1.4.4