CVE-2008-0780 — moin
CVE-2008-0780 is a Cross-site Scripting (XSS) vulnerability in moin. A fix is available for moin — see the affected versions and patch details below.
MoinMoin Cross-site scripting (XSS) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
moin🐍moinReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in MoinMoin 1.5.x through 1.5.8 and 1.6.x before 1.6.1 allows remote attackers to inject arbitrary web script or HTML via the login action.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | moin | ≥ 1.5 | No fix |
| 🐍PyPI | moin | ≥ 1.6&&< 1.6.1 | 1.6.1pip install --upgrade 'moin==1.6.1' |
Affected Products
moinmoinmoinmoinDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2008-0780; check the affected-versions list above or the advisory for the patched release of moin, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2008-0780 in your dependencies?
Find it across PyPI, including transitive dependencies.