Renovate vulnerable to arbitrary command injection via kustomize manager and malicious helm repositoryGHSA-xv56-3wq5-9997
MEDIUMGHSA-xv56-3wq5-9997 is a medium-severity (CVSS 6.7) CWE-77 vulnerability in renovate. A fix is available for renovate — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
renovatenpmDescription
Summary
The user-provided chart name in the kustomize manager is appended to the helm pull --untar command without proper sanitization.
Details
Adversaries can provide a maliciously crafted kustomization.yaml in conjunction with a Helm repo's index.yaml file to trick Renovate to execute arbitrary code.
The value for the depName argument for the helmRepositoryArgs function in lib/modules/manager/kustomize/artifacts.ts is not being escaped using the quote function from the shlex package.
This lack of proper sanitization has been present in the product since version 39.218.9 (https://github.com/renovatebot/renovate/commit/cc08c6e98f19e6258c5d3180c70c98e1be0b0d37), released on March 26 of 2025.
PoC
- Create a mock Helm repository. Have its
index.yamlendpoint return:
apiVersion: v1
entries:
"example || kill 1; echo":
- version: 1.0.1
created: 2016-10-06T16:23:20.499814565-06:00
- version: 1.0.0
created: 2016-10-06T16:23:20.499543808-06:00
- Create a git repo with the following content:
renovate.json5:
{
$schema: "https://docs.renovatebot.com/renovate-schema.json",
postUpdateOptions: [
"kustomizeInflateHelmCharts",
]
}
kustomization.yaml:
kind: Kustomization
apiVersion: kustomize.config.k8s.io/v1beta1
helmCharts:
- name: "example || kill 1; echo"
repo: TODO reference the mocked Helm repository over https
version: 1.0.0
with the todo resolved
charts/.gitkeep:
(empty)
- Run Renovate against the repo from a Docker container. Notice that the process terminates without reporting "Repository finished", because the ACI vulnerability allowed for execution of
kill 1, terminating the root process of the container.
Impact
This is a Arbitrary Command Injection vulnerability, allowing those with write access on repositories configured to be scanned by Renovate to cause the execution of commands of their choice on the machine that runs Renovate.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | renovate | ≥ 39.218.0&&< 40.33.0 | 40.33.0npm install renovate@40.33.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for renovate, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update renovate to 40.33.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xv56-3wq5-9997 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat does not ship or use an affected version of Renovate. The vulnerability affects Renovate 39.218.0 up to (but not including) 40.33.0 and was fixed in 40.33.0 (GHSA-5gfg-jpw3-fppq).
Red Hat products are not affected (see statement). Upstream, the issue is resolved by upgrading Renovate to 40.33.0 or later; it can also be mitigated by restricting repository write access so untrusted users cannot introduce a malicious kustomization.yaml.Source: Red Hat security advisory for GHSA-xv56-3wq5-9997 (CC BY 4.0)
Frequently Asked Questions
Is GHSA-xv56-3wq5-9997 in your dependencies?
Find it across npm, including transitive dependencies.