Renovate affected by remote code execution was possible using the bazel-module or bazelisk managers, when using lockFileMaintenanceGHSA-5vjq-5jmg-39xq
MEDIUMGHSA-5vjq-5jmg-39xq is a medium-severity (CVSS 6.3) OS Command Injection vulnerability in renovate. A fix is available for renovate — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-5vjq-5jmg-39xq.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
renovatenpmDescription
When using lockFileMaintenance using the bazel-module or bazelisk managers between Renovate 43.65.0 (2026-03-12) and 43.102.11 (2026-04-02), there was the opportunity for remote code execution from a malicious dependency, if the Bazel module executes code that relies on a dependency.
As this is an "unsafe" execution path, we have disabled this by default, and self-hosted administrators must add it to the allowedUnsafeExecutions allowlist.
It is recommended to review whether you have enabled this functionality for these managers, and if so, whether any dependency updates may have led to remote code execution.
Impact
If Renovate suggested an update to a malicious dependency, and that dependency is referenced as part of the bazel mod deps call - for instance as part of a ctx.execute call - this would call attacker-controlled code.
This could lead to insider attackers and outside attackers, executing code that is distributed as part of the package.
Patches
This is patched in 43.102.11.
This does not affect any versions of Mend Renovate Self-Hosted.
Workarounds
- Upgrade your Renovate version
- Disable
lockFileMaintenancefor these managers
Why did this happen?
This was missed in code review (as part of https://github.com/renovatebot/renovate/pull/41507).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | renovate | ≥ 43.65.0&&< 43.102.11 | 43.102.11npm install renovate@43.102.11 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for renovate, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update renovate to 43.102.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5vjq-5jmg-39xq is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-5vjq-5jmg-39xq in your dependencies?
Find it across npm, including transitive dependencies.